deprecated- все статьи тега


Как заменить функцию FeatureDetector в новом OpenCV?

Я скачал пример кода Java OpenCV. В нескольких строках кода есть метод FeatureDetectore(), который компилятор считает устаревшим. FeatureDetector detector = FeatureDetector.create(FeatureDetector.MSER); detector.detect(mGrey, keypoint); listpoint = keypoint.toList(); Итак, как я должен заменить эту часть кода? Есть ли для этого какая-то новая альтернатива? или я могу продолжить использование устаревшей функции? ...

Uidevice uniqueIdentifier устарел - что теперь делать?

только что выяснилось, что свойство uidevice uniqueIdentifier устарело на iOS5 и выше. Альтернативный метод или свойство не представляется доступным или предстоящим. многие из наших существующих приложений тесно зависит от этого свойства для уникальной идентификации конкретного устройства. Может кто-нибудь предложить какие-либо идеи, как мы можем справиться с этой проблемой в будущем? предложение из документации есть... Особые Соображения не используйте свойство uniqueIdentifier. Что ...

Замена для устаревшего sizeWithFont: в iOS 7?

в iOS 7, sizeWithFont: теперь устарел. Как теперь передать объект UIFont в метод замены sizeWithAttributes:? ...

getResources().getColor () является устаревшим [дубликат]

этот вопрос уже есть ответ здесь: getColor (int id) устарел на Android 6.0 Marshmallow (API 23) 17 ответов используя: buildToolsVersion "22.0.1" , targetSdkVersion 22 в моем файле gradle. Я нашел, что полезно getResources().getColor(R.color.color_name) устарела. что я должен использовать вместо этого? ...

Как объявить или пометить метод Java как устаревший?

Я хотел бы сделать один из моих методов "устаревшие" = больше не используется. но все же я хотел бы иметь его в моем API. Я просто хочу показать "предупреждение" любому, кто использует этот метод. Как я могу этого достичь? ...

Расширение mysql устарело и будет удалено в будущем: вместо этого используйте mysqli или PDO [дубликат]

этот вопрос уже есть ответ здесь: Почему я не должен использовать функции mysql_* в PHP? 14 ответов когда я пытаюсь подключиться к серверу MySQL с PHP, я вижу следующую ошибку: Deprecated: расширение mysql является устаревшим и будет удалено в будущем: используйте mysqli или PDO вместо этого /путь/имя_файла.php on line 123 код в указанной строке: mysql_connect($server, $username, $password); Я у ...

Как игнорировать предупреждения об устаревании в Python

Я продолжаю получать это: DeprecationWarning: integer argument expected, got float Как я могу сделать это сообщение уйти? Есть ли способ избежать предупреждений в Python? ...

Является ли" shouldOverrideUrlLoading " действительно устаревшим? Что я могу использовать вместо этого?

у меня есть вопрос/проблема, действительно ли "shouldOverrideUrlLoading" устарел? Если да, то что я могу использовать вместо этого? кажется shouldOverrideUrlLoading осуждается таргетинг на Android N и мне нужно, чтобы приложение работало с API 19 до последнего прямо сейчас, который является Android N (бета), я использую некоторые функции, которые являются новыми В Android N (например, Data Saver), поэтому таргетинг Marshmallow не поможет с этой проблемой, так как мне нужно использовать эти новы ...

FacebookSdk.sdkInitialize (контекст) является устаревшим

Я использую facebook-android-sdk-4.19.0 в Android Studio, и я следовал руководству по быстрому запуску Facebook в https://developers.facebook.com/docs/android/getting-started (Нажмите на кнопку быстрого запуска, чтобы войти в свою учетную запись facebook). В руководстве предлагается скопировать и вставить следующий код в фрагмент для отслеживания журналов приложений import com.facebook.FacebookSdk; import com.facebook.appevents.AppEventsLogger; public class MyApplication extends Application { ...

setBackgroundDrawable() устарел

Так что мой sdk идет от 15 до 21 и когда я звоню setBackgroundDrawable(), Android Studio говорит мне, что он устарел. Я думал обойти его с помощью: int sdk = android.os.Build.VERSION.SDK_INT; if(sdk < android.os.Build.VERSION_CODES.JELLY_BEAN) { layout.setBackgroundDrawable(getResources().getDrawable(R.drawable.img_wstat_tstorm)); } else { layout.setBackground(getResources().getDrawable(R.drawable.img_wstat_tstorm)); } но тогда, я получаю ошибку в " setBackground ()". Итак, как ...