Spring Boot: SpringBootServletInitializer является устаревшим


Я пытаюсь развернуть приложение Spring Boot в JBoss, следуя этой. Он работал хорошо, но SpringBootServletInitializer является устаревшим в 1.4.0.ОСВОБОЖДАТЬ. Какой из них я должен использовать?

Maven depedency

<parent>
    <groupId>org.springframework.boot</groupId>
    <artifactId>spring-boot-starter-parent</artifactId>
    <version>1.4.0.RELEASE</version>
</parent>

Java-Код

 import org.springframework.boot.SpringApplication;
 import org.springframework.boot.autoconfigure.EnableAutoConfiguration;
 import org.springframework.boot.autoconfigure.SpringBootApplication;
 import org.springframework.boot.context.web.SpringBootServletInitializer;

    @SpringBootApplication
    public class DemoApplication  extends SpringBootServletInitializer {
        public static void main(String[] args) {
            SpringApplication.run(DemoApplication.class, args);
        }
    }
1   51   2016-08-09 08:52:25

1 ответ:

вы используете org.springframework.boot.context.web.SpringBootServletInitializer Это не рекомендуется. Вместо этого:

использовать

org.springframework.boot.web.support.SpringBootServletInitializer

Для SpringBoot 2.0

org.springframework.boot.web.servlet.support.SpringBootServletInitializer