Установите Yarn Ubuntu 16.04 (Linux Mint 18.1)



У меня есть новая установка Linux Mint 18.1 с Ubuntu 16.04. Я установил узел 6.10.0.

при выполнении команды, которая указывает на документацию Yarn:

sudo apt-get update && sudo apt-get install yarn

Он говорит "не удалось найти пакет пряжи"

Я должен сделать что-то еще, потому что в документации я не вижу ничего об этом.

спасибо.

enter image description here

178   4  

4 ответов:

на Ubuntu Linux вы можете установить Yarn через репозиторий пакетов Debian. Сначала вам нужно будет настроить репозиторий:

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list

затем вы можете просто:

sudo apt-get update && sudo apt-get install yarn

дополнительная информация здесь

Я не смог установить Yarn на Ubuntu 16.04, используя принятый ответ, но нашел его легким с npm:

npm install -g yarn

затем проверьте install / version с помощью

yarn --version

см. На установка | Yarn / Linux tab

есть инструкции для нескольких дистрибутивов linux

вот более подробная информация о инструкция по установке.

  1. apt-key команда получает открытый ключ аутентификации для проверки интеграции программного обеспечения.

  2. deb https://dl.yarnpkg.com/debian/ stable main это репозиторий Ubuntu, содержащий yarn. Посмотрите на скриншот OP, в верхних строках 10 перечислены существующие репозитории для поиска пакетов, но нет ни одного yarn. Поэтому нам нужно добавить репозиторий, создав файл /etc/apt/sources.list.d/yarn.list.

  3. после вышеуказанных двух шагов, выпуск apt/

    Ничего не найдено.

Добавить ответ:
Отменить.